Madshrimps Forum Madness

Madshrimps Forum Madness (http://www.madshrimps.be/vbulletin/)
-   General Madness - System Building Advice (http://www.madshrimps.be/vbulletin/f18/)
-   -   levicom 550W PSU? (http://www.madshrimps.be/vbulletin/f18/levicom-550w-psu-3290/)

RichBa5tard 23rd October 2003 23:12

levicom 550W PSU?
 
Check this baby out. Fancy looks, 550W, and very reasonably priced at 85 euro. It even has a dedicated S-ATA dongle!

Has anyone seen a review of this puppy? Can't find any with google.

jmke 23rd October 2003 23:16

globalwin also has a 550W PSU out, also with SATA power connectors, pretty flashy:

The Senile Doctor 24th October 2003 15:20

I just need reviews, because I've been looking at that levicom also...

jmke 24th October 2003 15:27

what do you look for in such a "review" ?

FreeStyler 24th October 2003 15:36

the fact that I barely trust a 400+W PSU under 100 let alone one of 500+W

And the EMI of one of those has got to be horrible.

jmke 24th October 2003 16:01

afaik the EMI would be determined by a global organisation, and no company can release a product without a valid certification of compliance...

The Senile Doctor 24th October 2003 16:21

rails that withstand exreme strain is what I look for,
for as far as this can be tested

RichBa5tard 24th October 2003 16:31

Quote:

Originally posted by FreeStyler
the fact that I barely trust a 400+W PSU under 100 let alone one of 500+W

And the EMI of one of those has got to be horrible.

My QTek 550W costed 55. It has a very stable 5 & 12V line and except of the lack of a power switch on the back i can't find anyting wrong with it.

jmke 24th October 2003 16:44

Quote:

Originally posted by calantak
for as far as this can be tested
what would be a "acceptable" way to do this?

the P4 stresses the 12v

Tarantula 24th October 2003 17:53

Quote:

Originally posted by RichBa5tard


My QTek 550W costed 55. It has a very stable 5 & 12V line and except of the lack of a power switch on the back i can't find anyting wrong with it.

My Q-Tek 550W's 12V line sucks atm, when vcore is about 1,9V, my 12 V line drops to about 11,51:grum:


All times are GMT +1. The time now is 09:31.

Powered by vBulletin® - Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO