Madshrimps Forum Madness

Madshrimps Forum Madness (http://www.madshrimps.be/vbulletin/)
-   Air - Water - Peltier - Phase Change - LN2 Cooling Projects (http://www.madshrimps.be/vbulletin/f9/)
-   -   Swiftech MCX4000: crappy fan (http://www.madshrimps.be/vbulletin/f9/swiftech-mcx4000-crappy-fan-768/)

ModdiN MansoN 12th October 2002 16:23

Swiftech MCX4000: crappy fan
 
Yesterday, I bought an MCX4000 P4-blower from Swiftech, the one discussed in THIS [M]-article.
After installing this baby, I booted my pc, but I noticed the fan didn't start spinning, I gave it a tap with my finger, but the thing wouldn't move at all, so I shut down my system.
I unscrewed the fan from the heatsink and booted my pc again, the fan started spinning!, I figured I must have turned the screws on the fan too tight, so I reinstalled it with the screws turned half way in. then I booted my pc again and everything seemed fine at first, but suddenly the fan slowed down and eventually stopped spinning again :grum:
I took the fan off the HS again, and booted my pc, the fan started spinning, but the moment the metal shell of the fan touched my case, you could see some sparks and the thing stopped again, I decided to measure the voltage difference between the case and the metal casing of the fan -> 10V !!! it seemed like there was something very wrong with the fan, so I opened it:



if you look closely you can see some wires running to each corner, I decided to put some tape in all the places where the wires could possibly touch the metal shell and I closed the thing again, reinstalled the fan and it worked like it should from then on.

I feel ripped-off becouse this flaw was no production error, it is a flaw in the design and I can't believe this fan has been tested for more than one day.
For a blower that cost me 80 €uro's I expected to to recieve something decent, but it seems that just happens in my dreams :rolleyes:

Bosw8er 12th October 2002 16:30

I'm surprised you didn't hear about the bunch of errors that surrounded this fan. There was a big article about it at [H] and a lot of other sites.

Production is stopped atm .. i think

RichBa5tard 12th October 2002 17:03

Wow, seriuos production error!

I wonder why no-one seem to have noticed this before??

TeuS 12th October 2002 19:00

production stopped... i hope shops will sell later 80mm's, they give a great performance :o

jmke 13th October 2002 00:45

hmm sorry to hear that :/
I didn't experience any problems with the Swiftech fan here though. But it is very possible that it was a hit or miss. My sample didn't have the mentioned problem

Where did you buy it?

ModdiN MansoN 13th October 2002 12:23

I got it from comtech

the thing's dead again btw., but I was going to put a normal 80mm fan on it anyway

TeuS 13th October 2002 12:30

Quote:

Originally posted by ModdiN MansoN
I got it from comtech

the thing's dead again btw., but I was going to put a normal 80mm fan on it anyway

i could use such a fan, and perhaps i could fix yours...

ModdiN MansoN 13th October 2002 14:01

€5 and it's yours :D

TeuS 13th October 2002 18:31

Quote:

Originally posted by ModdiN MansoN
€5 and it's yours :D
if i can get it perfectly working, ok :super:
you often see bicker? so he could send it along with my lcd's

ModdiN MansoN 13th October 2002 19:11

I've never seen Bicker before and I doubt if I will in the near future


All times are GMT +1. The time now is 11:41.

Powered by vBulletin® - Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO