It appears you have not yet registered with our community. To register please click here...

 
Go Back [M] > Madshrimps > WebNews
enable AHCI mode after installing Windows enable AHCI mode after installing Windows
Register FAQ Members List Calendar Search Today's Posts Mark Forums Read


enable AHCI mode after installing Windows
Reply
 
Thread Tools
Old 15th February 2009, 11:31   #1
Madshrimp
 
jmke's Avatar
 
Join Date: May 2002
Location: 7090/Belgium
Posts: 78,579
jmke has disabled reputation
Default enable AHCI mode after installing Windows

Not sure if this has been posted before, but I managed to successfully enable AHCI mode after installing Windows. Here's how...

AHCI (Advanced Host Controller Interface) is present on newer Intel chipsets such as 975X (ICH7), P965 (ICH8), and P35 (ICH9). AHCI mode is enabled in the BIOS and 3 settings are commonly available: IDE, AHCI, and RAID. The last two (AHCI and RAID) require a driver floppy and the F6 method when installing Windows XP otherwise the hard disks won't be detected.The problem is that if you installed Windows in IDE mode (ie you didn't use F6 and supply a driver disk), then simply changing the BIOS setting to AHCI mode and rebooting will cause Windows to fail and will require a repair install. Most people have been advising to reinstall Windows if you want AHCI enabled.

I managed to enable AHCI on Windows XP Professional for a Gigabyte P35-DS4 (ICH9R) without needing to reinstall. This should work on any P35 ICH9 based board

http://forums.pcper.com/showthread.php?t=444831
__________________
jmke is offline   Reply With Quote
Reply


Similar Threads
Thread Thread Starter Forum Replies Last Post
Windows XP Mode RC Now Available jmke WebNews 0 5th August 2009 15:30
Microsoft Official Confirms Windows XP Mode for Windows 7 jmke WebNews 0 29th April 2009 13:40
Microsoft Patch Tuesday: 5 Criticals, 2 Important, 1 Moderate Patch jmke WebNews 0 14th April 2009 18:47
Microsoft Security Bulletin Summary for September 2008 jmke WebNews 0 9th September 2008 19:20
ATI Catalyst 8.8 Officially Released jmke WebNews 3 21st August 2008 09:04
Microsoft Security Bulletin Summary for August 2007 jmke WebNews 0 14th August 2007 22:21
Windows Vista Review, Part 3: Installing Windows Vista jmke WebNews 0 11th November 2006 10:36
Microsoft Security Bulletin Summary for June 2006 jmke WebNews 0 14th June 2006 20:51
List of fixes included in Windows XP Service Pack 2 jmke WebNews 1 17th August 2004 15:03
Microsoft and STMicroelectronics Team to Enable High-Definition Windows Media 9 Conte Sidney WebNews 0 8th June 2004 06:47

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


All times are GMT +1. The time now is 08:57.


Powered by vBulletin® - Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO