It appears you have not yet registered with our community. To register please click here...

 
Go Back [M] > Hardware Madness > Hardware/Software Problems, Bugs
bad 7850? bad 7850?
Register FAQ Members List Calendar Search Today's Posts Mark Forums Read


bad 7850?
Closed Thread
 
Thread Tools
Old 19th November 2012, 21:31   #1
charles
 
Posts: n/a
Default bad 7850?

Hi guy's ! I have a Sapphire 7850 overclock edition with 2 gigs of ddr5 ram in a Gigabyte z77-d3h motherboard with 8 gigs of Kingston hyper x memory 1600 mhz.and a antec 500 earth watts power supply windows 7 64 bit. and a I5 3330 cpu.. ok when I surf the web or watch videos or movies all is great.But as soon as I play a game ,Dirt, BF3, or even an older game like Halo or far cry I get a black screen and no signal and the last sound heard is looping..only way out is to hold the power button and restart. there is never any message to say that there was an error ? I see others posting this on some other sites,but was wondering if anyone here has had this happen to them and any ideas to what is causing this .Btw, the temp before the crash was only 45 Celsius.and the cpu is not overclocked.nor is the video card ..everything is stock speeds .Thank you for any info

Last edited by charles : 20th November 2012 at 15:55.
 
Old 28th November 2012, 18:33   #2
[M] Reviewer
 
leeghoofd's Avatar
 
Join Date: Dec 2008
Posts: 3,159
leeghoofd Fully Registeredleeghoofd Fully Registeredleeghoofd Fully Registeredleeghoofd Fully Registeredleeghoofd Fully Registeredleeghoofd Fully Registeredleeghoofd Fully Registeredleeghoofd Fully Registered
Default

PSU going bad ? Can you try the videocard at a friends place ?
__________________
leeghoofd is offline  
Old 29th November 2012, 01:40   #3
charles
 
Posts: n/a
Default

I have tried the card in another computer yes and with the same results .And the other system has a Corsair HX750 750 watt power supply.so it's not lack of power. And again I have seen numerous complaints on this and other models of the HD 7850
 
Old 2nd December 2012, 19:25   #4
[M] Reviewer
 
leeghoofd's Avatar
 
Join Date: Dec 2008
Posts: 3,159
leeghoofd Fully Registeredleeghoofd Fully Registeredleeghoofd Fully Registeredleeghoofd Fully Registeredleeghoofd Fully Registeredleeghoofd Fully Registeredleeghoofd Fully Registeredleeghoofd Fully Registered
Default

GPU bad then
__________________
leeghoofd is offline  
Old 5th December 2012, 18:50   #5
charles
 
Posts: n/a
Default

Well I sent the card back and they are sending me another one ..Hope that this one runs better than the first one . I'll find out in a day or so . Thank you for the replies. I will post as soon as I test her out to let you know the results
 
Closed Thread


Similar Threads
Thread Thread Starter Forum Replies Last Post
SAPPHIRE Updates HD 7850 Family Stefan Mileschin WebNews 0 17th July 2012 08:56
PowerColor HD 7850 PCS+ 2 GB @ techPowerUp Stefan Mileschin WebNews 0 30th May 2012 08:02
HIS 7850 IceQ X Turbo @ PureOverclock Stefan Mileschin WebNews 0 29th May 2012 08:27
PowerColor HD 7850 PCS+ Review @ Neoseeker Stefan Mileschin WebNews 0 24th May 2012 09:45
XFX HD 7870 and 7850 Double Dissipation Stefan Mileschin WebNews 0 9th May 2012 09:37
HIS Launches HIS 7850 Fan 2 GB Stefan Mileschin WebNews 0 2nd April 2012 07:52
AMD launches Radeon HD 7850, 7870 Stefan Mileschin WebNews 0 6th March 2012 09:18
AMD Radeon HD 7850 & HD 7870 2 GB @ techPowerUp Stefan Mileschin WebNews 0 5th March 2012 08:20
AMD Athlon 7850 Overclocking jmke WebNews 0 28th April 2009 14:35
AMD Athlon X2 7850 BE @ jmke WebNews 0 28th April 2009 14:33

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


All times are GMT +1. The time now is 15:30.


Powered by vBulletin® - Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO