The Creative X-Fi Scandal - Popping and crackling noises ahoy!

@ 2006/05/02
The media around the world already covered it and revealed all these issues many months ago. Creative even confirmed some of these issues. Today after many months, we did a little research to find out what has happened since then. We found out that only a few manufacturers have released BIOS updates to solve some of these issues. Creative has made a mysterious firmware upgrade that cannot be found on their website, and some users claimed it killed their card. According to users in their forums, most of the effected consumers are STILL having issues with the X-Fi series
Comment from jmke @ 2006/05/05
that's just bad for everybody

didn't know about that.
Comment from Sugarbabe @ 2006/05/05
JMKE,

it is simple, the article is poorly written and is attacking/ misleading claiming that the 99% is in the minority. That clown regeneration even posted in other forums, use google to search and see how he and his site is beginning to get hated lol.

Nobody is bashing the minority, we are just pointing out that Crapgeneration writes very lousy editorial material.

THE 99% who tried to post in the forum over at NGOHQ gets selectively deleted, now that is the reason why he is being attacked. It is his policies that is getting him negative vibes. Check 3dguru http://forums.guru3d.com/showthread.php?t=181332&page=3 It is the same story.
Comment from jmke @ 2006/05/05
what language or they typing there at HardwareZone?

Quote:
the author is the owner of the site.. 'Eraserhead' frm the forum got banned juz cos of juz of tryin to explain to him more... this type of admin can go fark spider sia.. and suddenly so many ppl reg juz to post.. 1 of them mention abt the traffic is almost none existence in the forum therefore the admin cre8ed that topic.. he got wat he wished for wif so many new users signed up.... zzz..
it's like a said before, if 99% is happy of 100.000, than 1000 DO have problems; if those 1000 dont get help, they can make enough noise to be heard.

it's not fair of the other 99.000 to attack those 1000 and state that they are liars. to that I just say: "wait until you run into problems with your creative card..."
Comment from Sugarbabe @ 2006/05/05
I have the X-Fi Plat and it works fine with no issues. The article in question seems to have questionable credibilty. Take a look at http://forums.hardwarezone.com/showt...5&page=1&pp=30 Majority like 99% are enjoying themselves than having problems, Stark contrast to the NGOHQ forum, I personally think they are skewing facts and impressions by deleting posts selectively.
Comment from Rutar @ 2006/05/04
Are their drivers KICKASS? yes

Are their products KICKASS= yes
Comment from jmke @ 2006/05/04
who, or what, is a Razer?

edit: http://www.razerzone.com/Products/Ga...11-Sound-Card/

?

darn... close to €200
Comment from Rutar @ 2006/05/04
Razer will save us all!
Comment from jmke @ 2006/05/04
Quote:
Originally posted by Major Major



Complaining about bad drivers is kind of lame if you can't even find them Not flaming, just a friendly pat on your shoulder, jmke and look at my sig, bro


oh yes, there is a very good reason why I'm complaining about "bad drivers" and "bad creative" support; I don't know why you are defending them? but that's maybe because you been lucky in the past?

I bought an Audigy 2 ZS Pro Platinum, you know, the $300 on, I can not get it to work correctly with the creative drivers installed, the system hangs during anything SOUND related; I had to install the great [g]KXdrivers[/g] in order to even USE the soundcard in my system. it's a WIDEspread issue even with the Audigy 2 series;

look here: http://forums.creative.com/creativel...audi gy+crash
and check the amount of hits you get.

this is the "mother load" of the Audigy 2 "horrible noise -> BSOD" stories, pretty long, but if you see the amount of people who have problems and are reporting in, and how many people resolved their issues... you might be surprised at the solution ...

"buy another none-creative soundcard"




and this doesn't exist because Creative has good support driver wise... http://www.petitiononline.com/mod_pe...d.cgi?creative

and right after the release of the Xi-Fi to the public about 100 threads popped up in their support forums about "crackling noises, and BSOD when the card is installed."

I'm happy to spread the news from ngohq, just check it out for yourself the amount of current issues: http://forums.creative.com/creativel...d=soundblaster
Comment from Major Major @ 2006/05/04
sorry for subsequent posts, but editing does not work for me and my sig does not show... So my sig was:
"Only Haters Lose"
Comment from Major Major @ 2006/05/04
@jmke 1: this is old news, 4-6 months or so. I suggest you read the comment thread under this article, it's fun. I mean
these guys are sponsored by another company that does sound cards, it's pretty obvious if you read their posts, lol

@jmke 2: Creative Sound Blaster Audigy, Audigy 2 series and Audigy 4 series Universal driver version 02.08.0004 has been released on 24th of January 2006, i.e. 3 months ago:
http://uk.europe.creative.com/suppor...ame=Windows+XP
Audigy has been launched in 2001 so this is 5 years by now. I do not know how many drivers were released in between but numbering suggests there were quite a few. As you can see there is a universal driver now so Audigy card seems to be supported...

Complaining about bad drivers is kind of lame if you can't even find them Not flaming, just a friendly pat on your shoulder, jmke and look at my sig, bro
Comment from jmke @ 2006/05/02
Is anybody surprised? after seeing how good they support their Audigy series...

 

reply